Sygic Aura 2.1.2 Android

[Login or Register to remove this advertisement]

Sygic Aura 2.1.2
Requirements: Android 2.x + GPU capable of OpenGL ES
Overview: No activation needed
Maps are downloaded over wifi with aura Direct Downloader




Many to undercode

More Info:
Code:
Code:
Only the registered members can see the CODE Contents. Please Login OR Register.

Download Instructions:
Code:
Only the registered members can see the CODE Contents. Please Login OR Register.
Mobile_Guru Reviewed by Mobile_Guru on . Sygic Aura 2.1.2 Android Sygic Aura 2.1.2 Android Sygic Aura 2.1.2 Requirements: Android 2.x + GPU capable of OpenGL ES Overview: No activation needed Maps are downloaded over wifi with aura Direct Downloader http://img205.imageshack.us/img205/7910/snap20110106004525.png http://img94.imageshack.us/img94/600/snap20101109192355.png Rating: 5