hello,
i have a gps mappy of 2012 of course map aren't ok, too old. there is a file with content,map and inside for example france.fbl and just fbl .can i use 2017Q4 because i downloaded file .map ?

[Login or Register to remove this advertisement]


thanks
boc4 Reviewed by boc4 on . gps mappy hello, i have a gps mappy of 2012 of course map aren't ok, too old. there is a file with content,map and inside for example france.fbl and just fbl .can i use 2017Q4 because i downloaded file .map ? thanks Rating: 5