[Android] Sygic Aura 2.1.2





Requirements:

Android 2.x + GPU capable of OpenGL ES

No activation needed

Maps are downloaded over wifi with aura Direct Downloader

[Login or Register to remove this advertisement]



All Credit to undercode

usitaly Reviewed by usitaly on . Sygic Aura 2.1.2 [Android] Sygic Aura 2.1.2 http://img94.imageshack.us/img94/600/snap20101109192355.png Requirements: Android 2.x + GPU capable of OpenGL ES Rating: 5